加入收藏 | 设为首页 | 会员中心 | 我要投稿 武汉站长网 (https://www.027zz.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDOJ 1002 A + B Problem II ( 大数相加)

发布时间:2021-02-18 13:48:05 所属栏目:大数据 来源:网络整理
导读:A + B Problem II(点击进入题目) Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 314071????Accepted Submission(s): 60860 Problem Description I have a very simple problem for you. G

A + B Problem II(点击进入题目)

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 314071????Accepted Submission(s): 60860


Problem Description I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
?
Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
?
Output For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
?
Sample Input
  
  
   
   2
1 2
112233445566778899 998877665544332211
  
  
?
Sample Output
  
  
   
   Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 2222222222222221110
  
  
?
Author Ignatius.L ?
Recommend We have carefully selected several similar problems for you:?? 1004? 1005? 1009? 1020? 1010? ?

模拟大数运算后注意输出的格式(英语好就不会是问题,我就是问题)。

代码:

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#define MYDD 1103

using namespace std;

int main() {
	int long_A,long_B,T;
	int sum[MYDD],a[MYDD],b[MYDD];
	char A[MYDD],B[MYDD];
	scanf("%d",&T);
	for(int t=1; t<=T; t++) {

		memset(sum,sizeof(sum));
		memset(a,sizeof(a));
		memset(b,sizeof(b));
		scanf("%s %s",A,B);

		long_A=strlen(A);
		long_B=strlen(B);
		int max_l=max(long_A,long_B);
		for(int j=long_A-1,i=0; j>=0; j--)
			a[i++]=A[j]-'0';
		for(int j=long_B-1,i=0; j>=0; j--)
			b[i++]=B[j]-'0';

		for(int j=0; j<max_l; j++) {
			sum[j]=a[j]+b[j]+sum[j];//包证前一位进位的数字要加上
			if(sum[j]>9) {
				sum[j+1]++;
				sum[j]-=10;
			}
		}
		printf("Case %d:n",t);

		for(int j=long_A-1; j>=0; j--)
			printf("%d",a[j]);

		printf(" + ");

		for(int j=long_B-1; j>=0; j--)
			printf("%d",b[j]);

		printf(" = ");

		if(sum[max_l]!=0)//首位是否为 0
			printf("%d",sum[max_l]);
		for(int i=max_l-1; i>=0; i--)
			printf("%d",sum[i]);
		printf("n");//保证格式正确 
		if(t!=T)
			printf("n");
	}
	return 0;
}

(编辑:武汉站长网)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    热点阅读